17.04.2017

1С:ERP Дополнительные внешние отчеты

Автор: Белозерских Евгений

   Начнем статью с постановки задачи, а именно!

   Необходимо добавить в базу данных новый разработанный отчет, который будет доступен из командного интерфейса пользователя.

Подготовка файла отчета

   Для того чтобы файл отчета (обработки) "понравился" конфигурации 1С:ERP, необходимо чтобы модуль объекта содержал 2 (две) функции и 1 (одну) процедуру:
  • Процедура ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование, ПоказыватьОповещение = Ложь, Модификатор = "")
  • Функция СведенияОВнешнейОбработке() Экспорт
  • Функция ПолучитьТаблицуКоманд()
   Ниже приведен код который должен содержаться в перечисленных функциях и процедурах модуля объекта
Функция СведенияОВнешнейОбработке() Экспорт
	ПараметрыРегистрации = Новый Структура;
	ПараметрыРегистрации.Вставить("Вид", "ДополнительныйОтчет");

	ПараметрыРегистрации.Вставить("Наименование",	"Отчет по закупкам");
	ПараметрыРегистрации.Вставить("Версия",			"1.0");
	ПараметрыРегистрации.Вставить("БезопасныйРежим", Ложь);
	ПараметрыРегистрации.Вставить("Информация",		"Отчет по закупкам");
	ПараметрыРегистрации.Вставить("ВерсияБСП",		"2.3.5.23");
	
	ТаблицаКоманд = ПолучитьТаблицуКоманд();
	ДобавитьКоманду(ТаблицаКоманд, "Отчет по закупкам",
					"1", "ОткрытиеФормы", Истина,"");
					
	ПараметрыРегистрации.Вставить("Команды", ТаблицаКоманд);
	
	Возврат ПараметрыРегистрации;
КонецФункции

Функция ПолучитьТаблицуКоманд()
	Команды = Новый ТаблицаЗначений;
	Команды.Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка"));
	Команды.Колонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка"));
	Команды.Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка"));
	Команды.Колонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево"));
	Команды.Колонки.Добавить("Модификатор", Новый ОписаниеТипов("Строка"));
	
	Возврат Команды;
КонецФункции

Процедура ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор,
					Использование, ПоказыватьОповещение = Ложь, Модификатор = "")

	НоваяКоманда = ТаблицаКоманд.Добавить();
	НоваяКоманда.Представление = Представление;
	НоваяКоманда.Идентификатор = Идентификатор;
	НоваяКоманда.Использование = Использование;
	НоваяКоманда.ПоказыватьОповещение = ПоказыватьОповещение;
	НоваяКоманда.Модификатор = Модификатор;
КонецПроцедуры
   После того как код в модуле объекта написан, конфигурация позволит нам добавить новый внешний отчет.

Настройка нового дополнительного отчета

   Первое что необходимо сделать (если не сделали до этого), это включить опцию использования дополнительных печатных форм, обработок и отчетов

НСИ и администрирование - Печатные формы, отчеты и обработки
Печатные формы, отчеты и обработки    Физически в конфигурации за хранение дополнительных печатных форм, отчетов и обработок отвечает одноименный справочник "ДополнительныеОтчетыИОбработки" (Синоним - "Дополнительные отчеты и обработки").
   Создавая новый элемент в этом справочник нам необходимо сразу загрузить в него необходимый файл (это событие вызывается автоматически при создании нового элемента).

   В открывшейся форме, нам необходимо указать для каких пользователей доступен быстрый доступ, а так же разместить вариант отчета в командном интерфейсе пользователя

Дополнительный отчет - Быстрый доступ
Дополнительный отчет - Размещение в разделах
   Если все сделано верно, то в командном интерфейсе указанных пользователей появится возможность вызвать необходимую настройку отчета!

Заключение

   Процесс разработки внешнего отчета для 1С:ERP, по сравнению с конфигурациями предыдущего поколения, усложнился не сильно. Изменились лишь требования к оформлению модуля объекта.
   Но вместе с тем, гибкость настройки и удобство использования улучшились принципиально! Что конечно не может не радовать!


Другие статьи

1С:ERP Заполнение индивидуального соглашения с клиентом

    В продолжение статьи рассмотрим возможности заполнения индивидуального соглашения с клиентом

1С:ERP Право отклонения от условий продаж

   Применение права отклонения от условий продаж указанных в соглашениях с клиентами

1С:ERP Индивидуальные соглашения в продажах

    Пример применения индивидуальных соглашений при продажах клиентам в с 1С:ERP

1C:ERP История изменений объектов (Версионирование)

    В статье описан механизм версионирования или хранения истории изменений объектов в конфигурации 1C:ERP, который претерпел значительные положительные изменения по сравнению с предыдущими реализациями

1С:ERP Виды работ сотрудников (Расценки)

   В статье рассмотрен справочник "ВидыРаботСотрудников" (синоним - "Виды работ сотрудников"), где применяются элементы данного справочника, и как указывается расценка на каждый из видов работ

1С:ERP Выпуск продукции (Простое производство без заказов)

   Многие специалисты знают документ из конфигурации 1С:УПП который называется "Отчет производства за смену", с помощью которого возможно отразить факт выпуска готовой продукции (просто выпуск без контура планирования производства). В этой статье мы рассмотрим аналог этого документа в 1С:ERP (просто выпуск и ничего лишнего)

1С:ERP Контроль остатков товаров

    Настройка контроля остатков товаров организаций в 1С:ERP

1C:ERP Формирование проводок (Отражение в регламентированном учете)

  Рассмотрим принципы и основные механизмы отражения документов в регламентированном учете в конфигурации "1С:ERP"

1C:ERP Настройка сведений о предприятии

   Настройки сведений о предприятии в конфигурации 1C:ERP

1С:ERP Краткий обзор настроек конфигурации

    Начнем работу! И рассмотрим основные настройки конфигурации, а также выполним первичное заполнение