08.06.2017

Список значений 1С

Автор: Белозерских Евгений

Список значений в платформе «1С:Предприятие»

    Список значений - это коллекция элементы которой могут содержать следующие атрибуты:
  • Значение
  • Представление
  • Пометка
  • Картинка
    При создании список значений пуст, т.е. сразу перечислить элементы коллекции нельзя. Их можно только добавлять:
НовыйСписок = Новый СписокЗначений;
НовыйСписок.Добавить("Значение", "Наименование", Ложь, );
    Значение элемента списка значений может быть любого (произвольного) типа

Методы списка значений

Сортировка списка значений (по значениям элементов списка, или по представлениям элементов списка)
НовыйСписок.СортироватьПоЗначению(НаправлениеСортировки.Возр);
НовыйСписок.СортироватьПоПредставлению(НаправлениеСортировки.Возр);
ВыбратьЭлемент - Вызывает окно для интерактивного выбора одного из элементов, входящих в список значений
Результат = НовыйСписок.ВыбратьЭлемент("Выберите нужный элемент списка");
Если НЕ Результат = Неопределено Тогда 
	Значение	= Результат.Значение;
КонецЕсли;
ПоказатьВыборЭлемента - Вызывает окно для интерактивного выбора одного из элементов, входящих в список значений
НовыйСписок.ПоказатьВыборЭлемента(Новый ОписаниеОповещения("ПродолжитьВыбор", ЭтаФорма));

&НаКлиенте
Процедура ПродолжитьВыбор(ВыбранныйЭлемент, СписокПараметров) Экспорт
    Если ВыбранныйЭлемент = Неопределено Тогда
        // Не выбрали
    Иначе
        ВыбранноеЗначение = ВыбранныйЭлемент.Значение;
    КонецЕсли;
КонецПроцедуры
ВыгрузитьЗначения - Создает массив и копирует в него значения элементов списка значений
Массив = НовыйСписок.ВыгрузитьЗначения();
ЗаполнитьПометки - Устанавливает пометку элементов списка
    // Установить пометку у всех строк.
    НовыйСписок.ЗаполнитьПометки(Истина);
    // Снять пометку у всех строк.
    НовыйСписок.ЗаполнитьПометки(Ложь);
Количество - Определяет количество элементов списка
Всего = НовыйСписок.Количество();
ОтметитьЭлементы - Позволяет интерактивно установить или снять пометки у элементов списка значений
Если НовыйСписок.ОтметитьЭлементы("Выберите необходимые элементы") Тогда
	// ....
КонецЕсли;
Очистить - Удалить все элементы списка значений
НовыйСписок.Очистить();




Другие статьи

Работа с файлами - Диалог выбора файла

    Простой пример организации выбора файла на управляемой форме «1С»

Отличие структуры от соответствия в «1С»

    «Соответствие» и «Структура» близкие по сути коллекции в платформе «1С:Предприятие». Обе коллекции представляют собой пару ключ и значение. Однако отличия все-таки есть

Примеры работы со строками в «1С» 8.3

    Примеры наиболее распространенных приемов при работе со строками в «1С»

Программная работа с торговым оборудование 1С 8.2

    В статье приведены примеры программного кода для подключения торгового оборудования, и обработки поступающих данных. Пример подходит для таких конфигураций как: Управление торговлей ред.10.3, Комплексная автоматизация ред.1.1, УПП ред. 1.3

Печать штрих-кода в 1С 8.2 (8.3)

    Практический пример вывода штрих-кода на печатную форму 1С

Работа с деревом значений в 1С 8.3

   В статье рассмотрены примеры программного кода для выполнения различных операций над реквизитом объекта с типом данных «Дерево значений»

Определить GUID по "<Объект не найден>..." 1С

     Программный код для определения GUID объекта базы 1С, на который есть ссылка, а самого объекта нет. Т.е. когда вместо объекта, строка вида "<Объект не найден> (52:fe9233554c4425daa3eef4a851abc631)"

Узнать версию платформы и конфигурации 1С программно

     Иногда требуется ограничить выполняемое действие если версия платформы или конфигурации не соответствует необходимой редакции. Рассмотрим как программно можно получить данную информацию.
 

Узнать версию платформы и конфигурации 1С

      Первое что нужно знать при работе в 1С, это используемая конфигурация, ее версия, а так же версия платформы "1С:Предприятие". Выяснить это достаточно просто.
 

Получить макет в управляемых формах 1С 8.3

Рассмотрим как можно получить макет объекта (отчета, обработки), когда методы объекта не доступны на сервере

Про управляемые формы 1С (Начало)

Самое самое самое простое (начальное) что необходимо знать про управляемые формы )

1С внешняя печатная форма

В статье рассматривается процесс создания внешней печатной формы для конфигурации на платформе "1С:Предприятие" работающей в режиме "Толстый клиент" обычное приложение

Проверка файловой базы данных 1С (chdbfl.exe)

Проверка физической целостности базы данных на платформе "1С:Предприятие" утилитой chdbfl.exe

Тестирование и исправление базы

Немного о том, какими способами осуществляется тестирование и исправление базы данных на платформе "1С:Предприятие"

Журнал регистрации 1С

В журнале регистрации 1С, фиксируются действия пользователей (добавление, изменение элементов справочников, документов, начало и завершение сеансов), а так же действия выполняемые фоновыми заданиями (запуск, завершение, а так же действия выполняемые в ходы работы задания)

Что такое платформа "1С:Предприятие"

Перед тем как начать разработку в среде 1С, необходимо определиться что же такое ПЛАТФОРМА, для чего она нужна и чего не будет без нее! Этому вопросу и посвящена данная статья.