22.04.2018

Чтение текстового файла в 1С

Автор: Белозерских Евгений

    При разработке учитываем что используем асинхронные вызовы в 1С (т.е. отказ от модальности), пример выбора файла с использованием асинхронных вызовов описан здесь.

Чтение файла на стороне клиента

    Для чтения данных из текстового файла на стороне клиента, можно использовать реквизит со специальным типом значения «ТекстовыйДокумент»

Реквизит управляемой формы с типом «ТекстовыйДокумент»
    Таким образом чтение данных можно выполнить одной строчкой кода:
РезультатНаКлиенте.Прочитать(ИмяФайла);

Чтение файла на стороне сервера

    Для чтения данных на стороне сервера, будем использовать внеконтекстный вызов функции, в которую параметром передадим адрес во временном хранилище. Итоговый код для команды загрузки данных будет выглядеть следующим образом:
&НаКлиенте
Процедура НачатьВыполнениеЗагрузки(Результат, Параметры) Экспорт
	
    Если НЕ Результат = КодВозвратаДиалога.Да Тогда
        Возврат;
    КонецЕсли;

	// Чтение данных через реквизит формы на стороне клиента
	РезультатНаКлиенте.Прочитать(ИмяФайла);
	
	// Чтение данных на стороне сервера
	РезультатЗагрузки	= ВыполнитьЗагрузкуНаСервере(АдресХранения);
	
КонецПроцедуры
	
&НаСервереБезКонтекста
Функция ВыполнитьЗагрузкуНаСервере(АдресХранения)

	Путь	= КаталогВременныхФайлов() +
				Новый УникальныйИдентификатор() + "temp.mxl";
	Файл	= ПолучитьИзВременногоХранилища(АдресХранения);
	
	Файл.Записать(Путь);
	
	ТекстовыйДокумент	= Новый ТекстовыйДокумент;
	ТекстовыйДокумент.Прочитать(Путь);
	
	Возврат ТекстовыйДокумент.ПолучитьТекст();
	
КонецФункции

Результат чтения файла на стороне клиента и сервера

Результат выполнения чтения данных текстового файла Скачать обработку для данного примера можно по этой ссылке.


Другие статьи

Функция вычисления контрольной цифры для штрихкода EAN-13 (EAN-8)

    Рабочая функция для вычисления контрольной цифры в штрихкоде формата EAN-13 или EAN-8

Чтение (Загрузка) данных из MXL в 1С 8.3

    Рабочий пример обработки чтения (загрузки) данных из MXL файла, с учетом отказа от использования модальных вызовов

Открыть форму выбора 1С 8.3

    Пример кода для открытия окна выбора элемента справочника, без использования модальных вызовов

Чтение и загрузка DBF в 1С 8.3

    Пример программного кода для чтения и/или записи файлов в формате DBF

Выгрузка объекта «1С» в XML и загрузка объекта из XML файла

    Пример выгрузки объекта информационной базы (СправочникОбъект, ДокументОбъект) «1С» в XML файл, и пример обратной загрузки объекта из XML файла

Выгрузка и загрузка XML через DOM

    Полезный пример того, как можно выгрузить в XML данные и загрузить обратно через DOM. Обработка осуществляется при помощи таких объектов как: ЗаписьXML, ЧтениеXML, ЗаписьDOM, ДокументDOM, ПостроительDOM.

HTTP запрос в 1С средствами «WinHttpRequest»

    Пример реализации HTTP запроса в 1С, средствами «WinHttpRequest» 

Программное изменение расписания фонового задания 1С 8.3

   Пример программного кода, для редактирования расписания выполнения фонового задания в 1С 8.3 в режиме отказа использования модальных вызовов

Оформление строк табличной части 1С 8.3

    Пример условного оформления элементов формы, в частности строк табличной части в 1С 8.3 (управляемые формы)

Обработка заполнения табличной части в 1С 8.3

    В статье рассматривается разработка обработки заполнения табличной части на примере конфигурации 1С:ERP
 

Запрос к таблице значений 1С 8.3

    В статье описан простой пример того, как можно сформировать запрос 1С к данным таблицы значений, т.е. как передать таблицу значений в параметр запроса
 

Динамическое создание колонок в таблице на форме 1С (Обычное приложение)

     Практический пример того, каким образом в таблице на форме (в режиме обычного приложения 1С), можно динамически создавать необходимое количество колонок, с возможностью установки обработки событий (например "ПриИзменении" в ячейке таблицы)

Динамическое создание колонок в таблице на форме 1С 8.3

      Практический пример того, каким образом в управляемом интерфейсе можно создавать и удалять колонки в таблице значений на форме

Чтение (загрузка) данных в 1С 8.3 из Excel

     Для передачи различной информации очень часто применяются табличные документы Excel. Переносить руками информацию из такого файла можно, но не удобно. Поэтому давайте рассмотрим, как можно программно в 1С обработать такой документ

Сохранение и восстановление настроек 1С 8.3

    Пример работы с хранилищем настроек 1C, для программного сохранения и получения сохраненных настроек

Внешняя печатная форма 1С 8.3

      Изменения в печатных формах, как и разработка новых, одна из самых распространенных задач. И для этих целей предназначен механизм внешних печатных форм, используемый в конфигурациях 1С.

Определение даты создания ссылки в 1С

Определяем дату создания ссылки по уникальному идентификатору объекта 1С

Программное создание команды и кнопки на форме 1С 8.3

Небольшой пример того, как программно создавать команды и элементы управления на управляемых формах 1С

Открыть форму созданного объекта (Справочник, документ в 1С 8.2, 8.3)

Создаем новый объект, НЕ записываем его в базу, и открываем форму