19.06.2017

Чтение и загрузка DBF в 1С 8.3

Автор: Белозерских Евгений

Чтение DBF файла средствами 1С

    Рассмотрим простой пример программного кода для чтения
&НаКлиенте
Процедура ПрочитатьФайл(Команда)
	ПрочитатьФайлНаСервере();
КонецПроцедуры

&НаСервере
Процедура ПрочитатьФайлНаСервере()
	ПутьКФайлу = "D:\dbf.DBF";

	ФайлDBF = Новый XBase;
	ФайлDBF.ОткрытьФайл(ПутьКФайлу, , Истина); // открытие файла
	ФайлDBF.Первая(); // устанавливает курсор на первую запись

	Пока НЕ ФайлDBF.ВКонце() Цикл
		// ФайлDBF[ИмяПоля№1]
		// ФайлDBF.ИмяПоля№1
		
		// Произвольный алгоритм
	КонецЦикла;

	// После чтения обязательно закрываем файл
	ФайлDBF.ЗакрытьФайл();
КонецПроцедуры

Создание и запись DBF файла средствами 1С

    Теперь рассмотрим пример создания DBF файла средствами 1С.
    Алгоритм на самом деле простой, единственное что от нас требуется, это описать состав и формат колонок, после чего заполнить строки файла. В нашем примере будет сформировано 10 строк в цикле:
&НаКлиенте
Процедура ЗаписьФайлаDBF(Команда)
	ЗаписьФайлаDBFНаСервере();
КонецПроцедуры

&НаСервере
Процедура ЗаписьФайлаDBFНаСервере()
	ФайлDBF = Новый XBase;

	ФайлDBF.Кодировка = КодировкаXBase.ANSI;
	
	// Создаем описание колонок
	ФайлDBF.Поля.Добавить("ColNum1", "S", 100);
	ФайлDBF.Поля.Добавить("ColNum2", "N", 10) ;

	ПутьФайла = "D:\dbf.DBF";
	ФайлDBF.СоздатьФайл(ПутьФайла);
	ФайлDBF.Записать();
	
	Для Индекс = 1 По 10 Цикл
		ФайлDBF.Добавить();
		ФайлDBF.ColNum1 = "Значение колонки " + Индекс;
		ФайлDBF.ColNum2 = Индекс;
		ФайлDBF.Записать();
	КонецЦикла;
	
	ФайлDBF.ЗакрытьФайл();
КонецПроцедуры
    Обратим внимание что действия выполняются на стороне сервера.

Другие статьи

Чтение текстового файла в 1С

    Пример чтения данных текстового файла (на клиенте и сервере) при разработке в режиме управляемого приложения 1С

Чтение (Загрузка) данных из MXL в 1С 8.3

    Рабочий пример обработки чтения (загрузки) данных из MXL файла, с учетом отказа от использования модальных вызовов

Открыть форму выбора 1С 8.3

    Пример кода для открытия окна выбора элемента справочника, без использования модальных вызовов

Выгрузка объекта «1С» в XML и загрузка объекта из XML файла

    Пример выгрузки объекта информационной базы (СправочникОбъект, ДокументОбъект) «1С» в XML файл, и пример обратной загрузки объекта из XML файла

Выгрузка и загрузка XML через DOM

    Полезный пример того, как можно выгрузить в XML данные и загрузить обратно через DOM. Обработка осуществляется при помощи таких объектов как: ЗаписьXML, ЧтениеXML, ЗаписьDOM, ДокументDOM, ПостроительDOM.

HTTP запрос в 1С средствами «WinHttpRequest»

    Пример реализации HTTP запроса в 1С, средствами «WinHttpRequest» 

Программное изменение расписания фонового задания 1С 8.3

   Пример программного кода, для редактирования расписания выполнения фонового задания в 1С 8.3 в режиме отказа использования модальных вызовов

Оформление строк табличной части 1С 8.3

    Пример условного оформления элементов формы, в частности строк табличной части в 1С 8.3 (управляемые формы)

Обработка заполнения табличной части в 1С 8.3

    В статье рассматривается разработка обработки заполнения табличной части на примере конфигурации 1С:ERP
 

Запрос к таблице значений 1С 8.3

    В статье описан простой пример того, как можно сформировать запрос 1С к данным таблицы значений, т.е. как передать таблицу значений в параметр запроса
 

Динамическое создание колонок в таблице на форме 1С (Обычное приложение)

     Практический пример того, каким образом в таблице на форме (в режиме обычного приложения 1С), можно динамически создавать необходимое количество колонок, с возможностью установки обработки событий (например "ПриИзменении" в ячейке таблицы)

Динамическое создание колонок в таблице на форме 1С 8.3

      Практический пример того, каким образом в управляемом интерфейсе можно создавать и удалять колонки в таблице значений на форме

Чтение (загрузка) данных в 1С 8.3 из Excel

     Для передачи различной информации очень часто применяются табличные документы Excel. Переносить руками информацию из такого файла можно, но не удобно. Поэтому давайте рассмотрим, как можно программно в 1С обработать такой документ

Сохранение и восстановление настроек 1С 8.3

    Пример работы с хранилищем настроек 1C, для программного сохранения и получения сохраненных настроек

Внешняя печатная форма 1С 8.3

      Изменения в печатных формах, как и разработка новых, одна из самых распространенных задач. И для этих целей предназначен механизм внешних печатных форм, используемый в конфигурациях 1С.

Определение даты создания ссылки в 1С

Определяем дату создания ссылки по уникальному идентификатору объекта 1С

Программное создание команды и кнопки на форме 1С 8.3

Небольшой пример того, как программно создавать команды и элементы управления на управляемых формах 1С

Открыть форму созданного объекта (Справочник, документ в 1С 8.2, 8.3)

Создаем новый объект, НЕ записываем его в базу, и открываем форму