03.06.2017

Программная работа с торговым оборудование 1С 8.2

Автор: Белозерских Евгений

Введение

     В статье рассматривается ТОЛЬКО программный код для работы с торговым оборудованием. Т.е. подразумевается что ТО подключено, настроено, и работает!

Процедура подключение торгового оборудования

     Подключение торгового оборудования выполняется одной строчкой, и осуществляется при открытии формы
Процедура ПриОткрытии()
	
	ПолучитьСерверТО().ПодключитьКлиента(ЭтаФорма);
	
КонецПроцедуры

Обработка данных поступающих от ТО

     Если подключение прошло успешно, и никакой ругани ошибки не произошло, значит результат работы ТО будет доступен в процедуре формы «ВнешнееСобытие» (т.е. провели картой по считывателю магнитных карт, срабатывает «ВнешнееСобытие»)
Процедура ВнешнееСобытие(Источник, Событие, Данные)
	Сообщить("Источник: " + Источник);
	Сообщить("Событие: " + Событие);
	Сообщить("Данные: " + Данные);
КонецПроцедуры
     Соответственно в этой же процедуре должен располагаться алгоритм обработки поступивших данных.

Отключение ТО при закрытии формы

     Не забываем при закрытии формы выполнить отключении торгового оборудования
Процедура ПриЗакрытии()
	
	ПолучитьСерверТО().ОтключитьКлиента(ЭтаФорма);
	
КонецПроцедуры

Заключение

     Как видите особых трудностей при разработки своей формы, которая умеет общаться с торговым оборудованием, не наблюдается.
     Поэтому спасибо за внимание и удачи в разработках!


Другие статьи

Работа с файлами - Диалог выбора файла

    Простой пример организации выбора файла на управляемой форме «1С»

Список значений 1С

    Практические примеры работы со списком значений в платформе «1С:Предприятие»

Отличие структуры от соответствия в «1С»

    «Соответствие» и «Структура» близкие по сути коллекции в платформе «1С:Предприятие». Обе коллекции представляют собой пару ключ и значение. Однако отличия все-таки есть

Примеры работы со строками в «1С» 8.3

    Примеры наиболее распространенных приемов при работе со строками в «1С»

Печать штрих-кода в 1С 8.2 (8.3)

    Практический пример вывода штрих-кода на печатную форму 1С

Работа с деревом значений в 1С 8.3

   В статье рассмотрены примеры программного кода для выполнения различных операций над реквизитом объекта с типом данных «Дерево значений»

Определить GUID по "<Объект не найден>..." 1С

     Программный код для определения GUID объекта базы 1С, на который есть ссылка, а самого объекта нет. Т.е. когда вместо объекта, строка вида "<Объект не найден> (52:fe9233554c4425daa3eef4a851abc631)"

Узнать версию платформы и конфигурации 1С программно

     Иногда требуется ограничить выполняемое действие если версия платформы или конфигурации не соответствует необходимой редакции. Рассмотрим как программно можно получить данную информацию.
 

Узнать версию платформы и конфигурации 1С

      Первое что нужно знать при работе в 1С, это используемая конфигурация, ее версия, а так же версия платформы "1С:Предприятие". Выяснить это достаточно просто.
 

Получить макет в управляемых формах 1С 8.3

Рассмотрим как можно получить макет объекта (отчета, обработки), когда методы объекта не доступны на сервере

Про управляемые формы 1С (Начало)

Самое самое самое простое (начальное) что необходимо знать про управляемые формы )

1С внешняя печатная форма

В статье рассматривается процесс создания внешней печатной формы для конфигурации на платформе "1С:Предприятие" работающей в режиме "Толстый клиент" обычное приложение

Проверка файловой базы данных 1С (chdbfl.exe)

Проверка физической целостности базы данных на платформе "1С:Предприятие" утилитой chdbfl.exe

Тестирование и исправление базы

Немного о том, какими способами осуществляется тестирование и исправление базы данных на платформе "1С:Предприятие"

Журнал регистрации 1С

В журнале регистрации 1С, фиксируются действия пользователей (добавление, изменение элементов справочников, документов, начало и завершение сеансов), а так же действия выполняемые фоновыми заданиями (запуск, завершение, а так же действия выполняемые в ходы работы задания)

Что такое платформа "1С:Предприятие"

Перед тем как начать разработку в среде 1С, необходимо определиться что же такое ПЛАТФОРМА, для чего она нужна и чего не будет без нее! Этому вопросу и посвящена данная статья.