05.12.2016

Установка отбора в динамическом списке (1C 8.2, 8.3)

Автор: Белозерских Евгений

В этой статье мы рассмотрим программную установку отбора для динамического списка. И первое что мы отметим, это то что отбор будет устанавливаться в пользовательских настройках на стороне клиента.

Динамический список

Разместим на форме динамический список с именем "Остатки" и произвольным запросом:
	ВЫБРАТЬ
		ТоварыНаСкладахОстатки.Склад,
		ТоварыНаСкладахОстатки.Номенклатура,
		ТоварыНаСкладахОстатки.КоличествоОстаток КАК Количество
	ИЗ
		РегистрНакопления.ТоварыНаСкладах.Остатки КАК ТоварыНаСкладахОстатки
Динамический список (общая форма)

Очищаем отборы при открытии

При открытии формы, будем очищать пользовательские отборы, чтобы убедиться что работают только наши условия
&НаКлиенте
Процедура ПриОткрытии(Отказ)
	ОчиститьПользовательскиеНастройки(Остатки);
КонецПроцедуры

&НаКлиенте
Процедура ОчиститьПользовательскиеНастройки(Список)
	Для каждого ЭлементНастройки Из Список.КомпоновщикНастроек.ПользовательскиеНастройки.Элементы Цикл
		Если ТипЗнч(ЭлементНастройки) = Тип("ОтборКомпоновкиДанных") Тогда
			ЭлементНастройки.Элементы.Очистить();
			Прервать;
		КонецЕсли;
	КонецЦикла;
КонецПроцедуры

Добавляем реквизит "Склад" на форму

Т.к. отбор мы будем осуществлять по складу, то на форме разместим поле ввода для выбора склада.

Реквизит для фильтра на форме

Другие статьи

Транзакция не активна «1С:Предприятие»

  Давайте рассмотрим как правильно организовать работу с транзакциями в 1С

Запуск фонового задания в 1С

    Наглядный пример выполнения произвольного алгоритма в режиме фонового задания

Переопределение (подмена) формы при открытии

    Предлагаю рассмотреть пример того, как можно переопределить (подменить) открываемую форму на другую (произвольную)

Функциональные опции 1С 8.3 (Механизм, использование)

    Рассмотрим механизмы, назначение и применение функциональных опций в платформе "1С:Предприятие" 8.3. Для этого возьмем простую конфигурацию и проверим поведение системы при использовании функциональных опций.

Общие реквизиты 1С 8.3

Общий реквизит – это реквизит, добавляемый к нескольким объектам конфигурации. Так же общий реквизит может использоваться как составная часть специального механизма разделения данных
 

Выбор файла 1С 8.3

Диалог выбора файла и отказ от модальности в 1С 8.3

Получение данных динамического списка 1С 8.3

      Динамический список обеспечивает быстрый просмотр больших объёмов данных. Но получить дополнительную информацию, например количество строк в списке, напрямую мы не можем.
      Давайте рассмотрим то, как это можно сделать. Например получить таблицу значений по данным динамического списка

Представление объектов (ссылок) в 1С

Пара слов о том, как можно изменить получаемое представление объекта (ссылки) в 1С

Работаем с регистрами сведений

Разберем структуру таблиц регистров сведений в СУБД, механизмы предоставляемые платформой для операций чтения, записи и удаления записей периодических и непериодических регистров сведений, а также регистров подчиненных регистратору.

Версия 8.3.7 и приятные новшества

Приветствую! В данном обзоре предлагаю рассмотреть некоторые новшества в механизмах платформы 1С:Предприятие версии 8.3.7.